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KEY TERMS
• ascending

• cells

• descending

• header row

• merge cells

• Quick Tables

• sort

• split cells

• tables

LESSON SKILL MATRIX

Skill Exam Objective Objective Number

Creating a Table Use the Insert Table dialog box. 2.5.1
 Use Draw Table. 2.5.2
 Insert a Quick Table. 2.5.3
 Convert text to a table. 2.5.4

Formatting a Table Use a table to control page layout. 2.5.5

Managing Tables Sort content. 2.6.1
 Add a row to a table. 2.6.2
 Add a column to a table. 2.6.3
 Manipulate rows. 2.6.4
 Manipulate columns. 2.6.5
 Defi ne the header row. 2.6.6
 Convert tables to text. 2.6.7
 View gridlines. 2.6.8

6 Creating Tables
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 Creating Tables 141

Karen Archer is an executive recruiter. Many large companies hire her to fi nd pro-

fessional talent to fi ll communications and marketing executive positions within 

their fi rms. You were recently hired as her assistant, and although the business is 

small, you are expected to display a high degree of professionalism, confi dential-

ity, and integrity. Because it is a small business, you are asked to perform many 

different duties. One of your main duties is to assist Ms. Archer with the constant 

updating of tables that contain data related to current clients, potential clients, 

and potential candidates for placement. Microsoft Word’s table tools can help you 

successfully manage this information. In this lesson, you will learn to format lists 

as well as create, format, and manage tables.

CREATING A TABLE
A table, such as the one shown in Figure 6-1, is an arrangement of data made up of horizontal 
rows and vertical columns. Cells are the rectangles that are formed when rows and columns 
intersect. Tables are ideal for organizing information in an orderly manner. Calendars, invoices, 
and contact lists are all examples of tables that you see and use every day. Word provides several 
options for creating tables, including the dragging method, the Insert Table dialog box, table 
drawing tools, and the Quick Table method.

WileyPLUS Extra! features an 
online tutorial of this task.

Figure 6-1

A table created in Word The cell connects at 
the column and row.

End of cell marker. Use 
Show/Hide to display.

Rows are horizontally 
aligned.

Columns are 
vertically aligned. End of row marker

Inserting a Table by Dragging
In this exercise, you learn how easily and quickly you can create a table from the Table menu by 
dragging the mouse pointer to specify the number of rows and columns. Using this method, you 
can create a new empty table with up to eight rows and ten columns.

STEP BY STEP Insert a Table by Dragging

GET READY. Before you begin these steps, LAUNCH Microsoft Word and OPEN a new 
blank Word document.

 1. On the Insert tab, in the Tables group, click the Table button. The Insert Table menu 
appears.

 2. Point to the cell in the fi fth column, second row. The menu title should read 5�2 Table, 
as shown in Figure 6-2. Click the mouse button to create the table.
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 142 Lesson 6

 3. Click below the table and press Enter twice to insert a blank line.

 4. SAVE the document as tables in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

Using the Insert Table Dialog Box
The Insert Table dialog box lets you create large tables by specifying up to 63 columns and 
thousands of rows. In this exercise, you use the Insert Table dialog box to insert a table with nine 
columns and three rows. Note that in the Insert Table dialog box, you can click the up and down 
arrows or key in the number of columns and rows needed in a table.

STEP BY STEP Use the Insert Table Dialog Box

USE the document that is open from the previous exercise.

 1. On the Insert tab, in the Tables group, click the Table button. Select Insert Table from 
the menu. The Insert Table dialog box appears.

 2. In the Number of columns box, click the up arrow until 9 is displayed.

 3. In the Number of rows box, click the up arrow until 3 is displayed, as shown in Figure 6-3.

Figure 6-2

Insert Table menu

Select columns and 
rows with your mouse.

Table menu

Figure 6-3

Insert Table dialog box

AutoFit options

 4. Click OK to insert the table. You inserted a new table with 9 columns and 3 rows.

 5. Click below the table and press Enter twice to insert a blank line.

 6. SAVE the document in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

2.5.1

How do you create a 
table using the Insert Table 

dialog box?
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 Creating Tables 143

Drawing a Table
Word provides the option to draw complex tables using the Draw Table command, which lets 
you draw a table as you would with a pencil and piece of paper. The Draw Table command 
transforms the mouse pointer into a pencil tool, which you can use to draw the outline of the 
table, then draw rows and columns exactly where you need them. In this exercise, you use the 
Draw Table command from the Table menu.

STEP BY STEP Draw a Table

USE the document that is open from the previous exercise.

 1. On the View tab, in the Show group, click the check box to display the Ruler.

 2. On the Insert tab, in the Tables group, click the Table button. Select Draw Table from the 
menu. The pointer becomes a pencil tool.

 3. To begin drawing the table shown in Figure 6-4, click at the blinking insertion point and 
drag down and to the right until you draw a rectangle that is approximately 3 inches 
high and 6 inches wide.

Figure 6-4

Drawing a table
Use the horizontal and 
vertical rulers as a 
guide to draw a table.

 4. Starting at about 0.5 inch down from the top, click and drag the pencil from the left 
border to the right border to draw a horizontal line.

 5. Draw two more horizontal lines about 0.5 apart.

 6. Starting at about 1 inch from the left side, click and drag the pencil from the fi rst line 
you drew to the bottom to create a column.

 7. Move over about 1 inch and draw a line from the top of the table to the bottom. If you 
drew a line in the wrong position, click the Eraser on the Draw Borders group and 
begin again.

 8. Draw three more vertical lines about 1 inch apart from the fi rst horizontal line to the 
bottom of the table to create a total of six columns. Your table should look similar to 
Figure 6-4. Click the Draw Table button on Draw Borders to turn the pencil tool off.

 9. Click below the table and press Enter twice to create a blank line. If necessary, place 
your insertion point outside of the last cell, and then press Enter.

 10. SAVE the document in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

You have now seen three ways to insert a blank table. Text separated by commas, tabs, para-
graphs, or another character can also be converted to a table with the Convert Text to Table 
command on the Table menu.

Take Note

2.5.2

How do you draw a table?
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 144 Lesson 6

Troubleshooting  When drawing tables with the pencil tool, note that this tool will draw squares and 
rectangles as well as lines. If you are trying to draw a straight line and you move the pencil 
off your straight path, Word may think you are trying to draw a rectangle and insert one 
for you. If this happens, just click the Undo button on the Quick Access Toolbar and try 
again. It might take a bit of practice to master the difference between drawing straight 
lines and drawing rectangles.

Inserting a Quick Table
Quick Tables are built-in preformatted tables, such as calendars and tabular lists to insert and 
use in your documents. Word provides a variety of Quick Tables that you can insert into your 
documents. In this exercise, you will insert a Quick Table calendar into a document. The Quick 
Table calendar can be edited to refl ect the current month and year.

STEP BY STEP Insert a Quick Table

USE the document that is open from the previous exercise.

 1. On the Insert tab, in the Tables group, click the Table button. Select Quick Tables from 
the menu. A gallery of built-in Quick Tables appears, as shown in Figure 6-5.

Figure 6-5

Built-In Quick Table gallery
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 Creating Tables 145

 2. Select Calendar 2. The data in the calendar can be edited to display the current month 
and year.

 3. SAVE the document in the lesson folder on your USB fl ash drive, then CLOSE the fi le.

PAUSE. LEAVE Word open to use in the next exercise.

A table can be moved to a new page or a new document by clicking the move handle to select 
the table and then using the Cut and Paste commands. You can also use the Copy command to 
leave a copy of the table in the original location.

Take Note

2.5.3

How do you insert a 
Quick Table?

Figure 6-6

Design Tab on the Table 
Tools Ribbon

Table Tools are displayed on the 
Ribbon when a table is inserted.

Table Style 
Options group

Table Styles group Click the arrow to 
display the Tables 
Styles Gallery.

FORMATTING A TABLE
Once a table has been inserted into a document, a preformatted style can be applied using Quick 
Styles from the Table Styles and Table Style Options groups. Quick Styles add a professional ap-
pearance to the tables in your documents.

Applying a Quick Style to a Table
With Quick Styles, it easy to quickly change a table’s formatting. You can apply styles to tables 
in much the same way you learned to apply styles to text in previous lessons, by positioning the 
insertion point in the table before selecting a style from the Quick Styles gallery. You can preview 
the style before applying it and change the style as many times as needed. You can modify an 
existing Table Style or create a New Table Style and add it to the gallery, then modify or delete 
it, as appropriate. In this exercise, you apply a Quick Style to a table in your Word document.

STEP BY STEP Apply a Quick Style to a Table

 OPEN clients from the data fi les for this lesson.

 1. The insertion point is positioned in the table.

 2. On the Design tab, in the Table Styles group, click the More  button to view a gallery 
of Quick Styles.

 3. Scroll through the available styles. Notice that as you point to a style, Word displays a 
live preview, showing you what your table will look like if you choose that style.

The Bottom Line

          The clients fi le for 
this lesson is available 
on the book companion 
website or in WileyPLUS.

 SOFTWARE ORIENTATION

Design Tab on the Table Tools Ribbon

After inserting a table, Word displays Table Tools in the Ribbon, as shown in Figure 6-6. It is 
important to become familiar with the commands available in the Design tab under Table Tools. 
Use this fi gure as a reference throughout this lesson as well as the rest of this book.
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 146 Lesson 6

 4. Scroll down to the fourth row under the Built-in section and select the fourth style 
over in the row, the Medium List 2 – Accent 3 style, as shown in Figure 6-7.

Figure 6-7

Quick Style gallery

 5. SAVE the document as clients_table in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

Turning Table Style Options On or Off
Table Style Options enable you to change the appearance of the Quick Styles you apply to your 
tables. Table Style Options, which are linked to the Table Style you have selected, apply globally 
throughout the table. For example, if you select the Banded Columns option, all even-num-
bered columns in the table will be formatted differently than the odd-numbered columns. In 
this exercise, you learn to turn Table Style Options on or off by clicking each option’s check box.

Table Style Options include the following:

 • Header Row: Formats the top row of the table

 • Total Row: Formats the last row, which usually contains column totals

 • Banded Rows: Formats even rows differently than odd rows

 • First Column: Formats the fi rst column of the table

 • Last Column: Formats the last column of the table

 • Banded Columns: Formats even columns differently than odd columns

STEP BY STEP Turn Table Style Options On or Off

USE the document that is open from the previous exercise.

 1. The insertion point should still be in the table. If you click outside the table, the Design 
and Layout tabs will not be available.

 2. On the Design tab, in the Table Style Options group, click the First Column check box. 
Notice that the format of the fi rst column of the table changes, as do the Table Styles 
in the Quick Style gallery.

 3. Click the Banded Rows check box to turn the option off. Color is removed from the 
rows.

 4. Click the Banded Rows check box to turn it on again. Color is reapplied to every other 
row.

 5. SAVE the document in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

WileyPLUS Extra! features an 
online tutorial of this task.
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 Creating Tables 147

 SOFTWARE ORIENTATION
Layout Tab on the Table Tools Ribbon

When you are working with tables, Word displays a new contextual Table Tools ribbon that is 
only visible when a table is in use. The Table Tools Ribbon has two tabs: the Design tab and the 
Layout tab. The Layout tab, as shown in Figure 6-8, includes commands for changing the entire 
format of a table as well as commands for changing the appearance of individual table compo-
nents, such as cells, columns, and rows. Use this fi gure as a reference throughout this lesson as 
well as the rest of this book.

Figure 6-8

Layout Tab on the Table 
Tools Ribbon

Displays table 
gridlines

Commands for 
Rows & Columns

Dialog box 
launcher

Merge and Split 
Cells commands

AutoFit

Horizontal and Vertical 
Cell Alignment Options

Text Direction 
button

Sort Text button

Repeat Header 
Rows button

Formula button
Convert Table 
to Text button

Distributes columns 
evenly

Distributes rows 
evenlyHeightWidth

MANAGING TABLES
As with any document that you edit, some adjustments are always necessary when you work 
with tables. After you create a table, you can resize and move its columns; insert columns and 
rows; change the alignment or direction of its text; set the header row to repeat on several pages; 
organize data through sorting by text, number, or date; convert text and tables; merge and split 
cells; and work with the table’s properties. Word’s gridlines make all such edits easier.

Resizing a Row or Column
Word offers a number of tools for resizing rows or columns. You can resize a column or row a 
couple of ways using the mouse. You can use commands in the Cell Size group on the Layout 
tab to adjust height and width, and Word’s AutoFit command enables you to adjust column 
width to fi t the size of table contents, the window, or to fi t all content to a fi xed column width. 
In addition, the Table Properties dialog box allows you to set the measurements at a precise 
height for rows or ideal width columns, cells, and tables. In this exercise, you practice using these 
techniques to resize rows and columns in a Word table.

STEP BY STEP Resize a Row or Column

USE the document that is open from the previous exercise.

 1. On the Layout tab, in the Table group, click the View Gridlines button to display 
gridlines and enable more precise editing.

 2. Click in the fi rst column and position the mouse pointer over the horizontal ruler on 
the fi rst column marker. The pointer changes to a double-headed arrow along with the 
ScreenTip Move Table Column, as shown in Figure 6-9.

The Bottom Line
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 148 Lesson 6

 3. Click and drag the border to the right until the contents in the cell extend in a single 
line along the top of the cell.

 4. On the Layout tab, in the Cell Size group, click the AutoFit button to open the drop-
down menu, as shown in Figure 6-10. On the drop-down menu, click AutoFit Contents. 
Each column width changes to fi t the data in the column.

Figure 6-9

Horizontal Ruler on the fi rst 
column marker

Column marker on 
ruler. Columns can be 
adjusted manually by 
dragging.

Figure 6-10

AutoFit button and menu

 5. Position the insertion point in the phone number column of the table. In the Table 
group, of the Layout tab, click the Select button and choose Select Column from the 
drop-down menu.

 6. On the Layout tab, in the Cell Size group, click the up arrow in the Width box until it 
reads 1.1” and the column width changes.

 7. Place the insertion point anywhere in the fi rst row. In the Table group, click the Select 
button, then Select Row from the drop-down menu. The fi rst row is selected.

 8. On the Layout tab, in the Cell Size group, click the dialog box launcher. The Table 
Properties dialog box appears.

 9. Click the Row tab in the dialog box. Click the Specify height check box. In the Height 
box, click the up arrow until the box reads 0.5”, as shown in Figure 6-11.

 10. Click the Next Row button to apply your changes to the row that follows the selected 
row in the table. Notice the selection moves down one row. Click OK.

 11. Click in any cell to remove the selection.

 12. SAVE the document as clients_table1 in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

 Another Way
 Position the pointer 
outside the table, above the 
column containing the phone 
numbers. The pointer changes to 
a down selection arrow. Click to 
select the column.

 Another Way
 The Table 
Properties dialog box can be 
accessed from the shortcut 
menu by right-clicking 
anywhere in the table and 
selecting Table Properties.

2.6.5

How do you resize 
a column?

2.6.4

How do you resize a row?

How do you view gridlines?

2.6.8
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Moving a Row or Column
When working with tables, it is important to know how to rearrange columns and rows to bet-
ter display your data. By selecting the entire column or row, drag and drop is used for moving 
data to a new area in the table. The mouse pointer changes and resembles an empty rectangle 
underneath with dotted lines. In this lesson, you practice moving text from rows and columns.

Figure 6-11

Table Properties dialog box
Adjust row height

Moves to the 
prior row Advances to the next row

The Cut and Paste commands were covered Lesson 2.

STEP BY STEP Move a Row or Column

USE the document that is open from the previous exercise.

 1. In the table, select the fourth row of data, which contains the information for 
Proseware, Inc. In the Table group, click the Select button, then Select Row from the 
drop-down menu.

 2. The insertion point is positioned on the selected row, hold down the mouse button. 
Notice the mouse pointer changes to a move pointer with a dotted insertion point.

 3. Drag the dotted insertion point down and position it before the W in Wingtip Toys. 
Release the mouse button and click in the table to deselect. The row is moved to the 
position above the Wingtip Toys row.

 4. Place the insertion point in the second column of the table, which contains fi rst 
names. Click the Select button, in the Table group, then Select Column from the drop-
down menu.

 5. Position the pointer inside the selected cells and right-click to display the shortcut 
menu. Select Cut to delete that column of text and move the remaining columns to 
the left.

 6. Place the insertion point on the phone numbers column.

 7. Right-click to display the shortcut menu, then under the Paste Options section, click 
Insert as New Column. A new Paste Options menu is displayed with the options Insert 
as New Column, Nest Table, Insert as New Row, and Keep Text Only. Selecting the 
fi rst option to Insert as New Column; the fi rst name column is pasted to the left of the 
phone number column. Click anywhere in the table to deselect.

 8. SAVE the document as clients_table2 in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

Instead of using the shortcut menu, you can also use the Cut and Paste commands in the 
 Clipboard group on the Home tab to cut and move rows and columns.

Take Note

Ref 

NEW
to Offi ce 2010

2.6.4

How do you move 
a row?

2.6.5

How do you move 
a column?

c06CreatingTables.indd Page 149  01/08/11  9:40 AM user-f396c06CreatingTables.indd Page 149  01/08/11  9:40 AM user-f396 F-396F-396

LICENSED PRODUCT NOT FOR RESALE
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Setting a Table’s Horizontal Alignment
The horizontal alignment for a table can be set to the left or right margins or centered. Tables in-
serted into a report should align with the document to maintain the fl ow of the report. In this ex-
ercise, you will practice using the Table Properties dialog box to set a table’s horizontal alignment.

STEP BY STEP Set a Table’s Horizontal Alignment

USE the document that is open from the previous exercise.

 1. Position the insertion point anywhere inside the table. On the Layout tab, in the Table 
group, click the Select button, then Select Table.

 2. On the Layout tab, in the Table group, click the Properties button. The Table Properties 
dialog box appears.

 3. Click the Table tab, if necessary. In the Alignment section, click Center, as shown in
Figure 6-12.

Figure 6-12

Table Properties dialog box

 4. Click OK. The table is centered horizontally on the page. Click anywhere within the 
table to deselect.

 5. SAVE the document on your USB fl ash drive in the lesson folder.

PAUSE. Leave the document open to use in the next exercise.

Creating a Header Row
A header row is the fi rst row of the table that is formatted differently and should be repeated 
for tables that extend beyond one page. When you specify a header row in the Table Style Op-
tions group, the row is distinguished from the entire table. Column headings are usually placed 
in the header row. In this exercise, you will practice repeating heading rows for lengthy tables.

STEP BY STEP Create a Header Row

USE the document that is open from the previous exercise.

 1. Place the insertion point on the fi rst row of the table.

 2. On the Layout tab, in the Rows & Columns group, click Insert Above . A new 
blank row is inserted.

2.5.5

How do you set a table’s 
alignment?
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 Creating Tables 151

 3. On the Design tab, in the Table Style Options group, click the Header Row check box to 
apply a distinctive format to the header row.

 4. Key headings in each cell within the fi rst row of the table, as shown in Figure 6-13.

Figure 6-13

Header row

 5. Select the fi rst row of the table. On the Table group of the Layout tab, click the Select 
button and Select Row.

 6. On the Home tab, in the Font group, click the Bold  button. The header rows are bolded.

 7. On the Layout tab, in the Data group, click the Repeat Header Rows button. Scroll 
down and view the headings on the second page. Click anywhere in the table to 
deselect.

 8. SAVE the document as clients_table3 in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

Repeating rows are only visible in Print Layout view or on a printed document.

Sorting a Table’s Contents
To sort data means to arrange it alphabetically, numerically, or chronologically. Sorting 
displays data in order so that it can be immediately located. Text, numbers, or dates can be 
sorted in ascending or descending order. Ascending order sorts text from beginning to end, 
such as from A to Z, 1 to 10, and January to December. Descending order sorts text from the 
end to the beginning, such as from Z to A, 10 to 1, and December to January. In this exercise, 
you practice sorting data in a Word table using the Sort dialog box, which you access through 
the Sort command on the Layout tab in the Data group.

You can sort up to three columns of data in the Sort dialog box. Before beginning the sort pro-
cess, you must select the column (or columns) to be sorted.

STEP BY STEP Sort a Table’s Contents

USE the document that is open from the previous exercise.

 1. Place the insertion point on the fi rst column to select the Company Name column. On 
the Table group of the Layout tab, click the Select button and Select Column.

 2. On the Layout tab, in the Data group, click the Sort button. The Sort dialog box 
appears, as shown in Figure 6-14. The Company Name data is listed in the Sort By text 
box, with Ascending Order selected by default.

Take Note

Take Note

2.6.2

How do you insert a row 
in a table?

2.6.6

How do you defi ne a 
header row?

Figure 6-14

Sort dialog box

Identifies the order 
in which to sort 
your list

If your table has 
headings, select 
Header row.

Identify data as text, 
numbers, or dates for 
easier sorting.

Ascending order sorts 
from A to Z.

Descending order 
sorts from Z to A.
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 152 Lesson 6

 3. Click OK. Note that the table now appears sorted in ascending alphabetical order by 
company name.

 4. SAVE the document as clients_table4 in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

Merging and Splitting Table Cells
The ability to merge and split table cells provides fl exibility in customizing tables. To merge 
cells means to combine two or more cells into one. Merging cells is useful for headings that 
extend over several columns. To split cells means to divide one cell into two or more cells. 
Cells may be split when more than one type of data needs to be placed in one cell. The Split 
Cells dialog box enables you to split a cell into columns or rows. In this lesson, you practice us-
ing commands in the Merge group on the Layout tab to merge and split cells.

STEP BY STEP Merge and Split Table Cells

 USE the document that is open from the previous exercise.

 1. Position the insertion point on the header row located on page 1. Select the cell that 
contains the Contact Person heading and the empty cell to the right of it.

 2. On the Layout tab, in the Merge group, click the Merge Cells button. The selected 
columns merge into one cell.

 3. In the Position Title column, on the Lucerne Publishing row, select the cell that 
contains the text Director Marketing VP Public Relations.

 4. On the Layout tab, in the Merge group, click the Split Cells button.

 5. Click OK to accept the settings as they are. A new column is inserted within the cell, as 
shown in Figure 6-15.

2.6.1

How do you sort a 
table’s contents?

Figure 6-15

Cell split into two columns
One cell is split into 
two columns.

2.6.4

How do you merge
 rows?
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 6. Select the text VP Public Relations and drag and drop text to the new column.

 7. In the Company Name column, select the Woodgrove Bank cell.

 8.  Click the Split Cells button. The default setting for the Number of columns is 2, while 
the Number of rows is 1. The Merge cells before split check box is checked.

 9.  Change the Number of columns settings to 1 and the Number of rows setting to 2 to 
split the cell into a single column containing two rows, as shown in Figure 6-16.

Figure 6-16

Cell split into two rows

One cell is split into 
two rows.

 10.  Select the split cell and merge. Place the insertion point in front of Woodgrove Bank. 
Press and hold the mouse button to select the two rows within the column. On the 
Merge group, click the Merge Cells button. The cell is now a single row.

 11. Click the Undo  button.

 12. SAVE the document as clients_table5 in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

Changing the Position of Text in a Cell
Word provides you with nine options for aligning text in a cell. These options enable you to 
control the horizontal and vertical alignment of cell text, such as Top Left, Top Center, and Top 
Right. To change cell text alignment, select the cell or cells you want to align and click one of the 
nine alignment buttons in the Alignment group on the Layout tab. In this lesson, you practice 
changing the text alignment within a cell.

2.6.5

How do you merge 
columns?

2.6.4

How do you split cells 
by rows?

2.6.5

How do you split cells 
by columns?

 Another Way
You can access the 

Merge Cells command on the 
shortcut menu. The Merge Cells 
command is visible only when 
you have multiple cells selected 
in a table.
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STEP BY STEP Change the Position of Text in a Cell

USE the document that is open from the previous exercise.

 1. Select the table’s header’s row, with the headings on page 1. On the Layout tab in the 
Table group, click the Select button, then click Select Row.

 2. In the Alignment group, click the Align Center  button. The header row is centered 
horizontally and vertically within the cell.

 3. SAVE the document in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE the document open to use in the next exercise.

Changing the Direction of Text in a Cell
Rotating text in a cell provides additional options for creating interesting and effective tables. 
Changing the direction of text in a heading can be especially helpful. To change the direction of 
text in a cell, click the button three times to cycle through the three available directions. In this 
exercise, you practice changing the direction of text in a cell.

STEP BY STEP Change the Direction of Text in a Cell

USE the document that is open from the previous exercise.

 1. Select the cell that contains the Company Name heading.

 2. On the Layout tab, in the Alignment group, click the Text Direction button three times 
to rotate the text direction to align to the right cell border, the left cell border, and 
then back to the top cell border. As you click the Text Direction button, the button face 
rotates to match the rotation of the text direction in the selected cell.

 3. SAVE the document in the lesson folder on your USB fl ash drive.

PAUSE. LEAVE Word open to use in the next exercise.

Converting Text to Table or Table to Text
Text separated by a paragraph mark, tab, comma, or other character can be converted from 
text to a table or from a table to text. To convert text to a table, fi rst select the text, then click 
the Insert tab button, then click the Table button, and fi nally select Convert Text to Table. The 
Convert Text to Table dialog box will appear, and Word will determine the number of columns 
needed. In this exercise, you practice using this technique to convert Word text into a table.

STEP BY STEP Convert Text to Table or Table to Text

 OPEN the part_numbers document in your lesson folder.

 1.  Select the whole document.

 2.  On the Insert tab, on the Table group, click the Table button. The Table menu appears.

 3.  Click Convert Text to Table. The Convert Text to Table dialog box opens. Word recognizes 
the number columns and rows and places the number 10 in the Number of rows 
box—notice that it is shaded gray, making it unavailable to change. (See Figure 6-17.) 
Keep the default settings.

 4.  Click OK. The selected text was separated by paragraph marks and by selecting the 
default of one column, Word converts the text to a table, as shown in Figure 6-18.

 5.  SAVE the document as part_numbers_table in the lesson folder on your USB fl ash 
drive.

 6.  Position the insertion point anywhere in the table and click the Layout tab.

 7.  In the Table group, click the Select button, then click Select Table to select the entire 
table.

          The part_numbers 
fi le for this lesson is 
available on the book 
companion website or in 
WileyPLUS.

2.5.4

How do you convert text 
to a table?
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Figure 6-17

Convert Text to Table 
dialog box

The current number of columns and 
rows will be filled in automatically.

The AutoFit behavior default 
is set to Fixed column width. 

Identifies the character that 
will separate your cells of data

Figure 6-18

Document converted from text 
to a table

 8.  In the Data group, click Convert Table to Text. The Convert Table to Text dialog box 
opens. The default setting in the Convert Table to Text dialog box is Paragraph marks. A 
table can be converted to text and separated by paragraph marks, tabs, commas, and 
other characters (see Figure 6-19).

2.6.7

How do you convert a 
table to text?

c06CreatingTables.indd Page 155  01/08/11  9:40 AM user-f396c06CreatingTables.indd Page 155  01/08/11  9:40 AM user-f396 F-396F-396

LICENSED PRODUCT NOT FOR RESALE



 156 Lesson 6

 9.  Click OK. The document is converted to text separated by paragraph marks.

 10.  SAVE the document as part_numbers_text in the lesson folder on your USB fl ash 
drive, then CLOSE the fi le.

PAUSE. LEAVE Word open to use in the next exercise.

Inserting and Deleting a Column or Row
The Word Layout tab in the Rows and Columns group, makes it easy to insert a row above or 
below a column; to the left or right; and to delete cells, columns, rows, and table. In the exercise, 
you learn to insert a column and row and delete a row.

STEP BY STEP Insert and Delete a Column or Row

 OPEN the part_numbers_table documents in your lesson folder.

 1.  Place the insertion point on the fourth row.

 2.  On the Layout tab, in the Rows & Columns group, click the Insert Above button; a 
blank row is inserted above the fourth row.

 3.  The blank row is selected. Click the Delete button in the Rows & Columns group, then 
click Delete Row from the drop-down menu. The blank row is deleted from the table.

 4.  In the Cell Size group, click the AutoFit button, then select AutoFit Contents. The data 
in the table automatically resizes to fi t in the column width.

 5.  Place your insertion point anywhere in the table, and in the Row & Columns group, 
click Insert Right. A new column is inserted to the right.

 6.  On the Rows & Columns group, click the Delete button, then click Delete Column. The 
Delete button menu allows you to delete cells, rows, and the entire table.

 7.  SAVE the document in the lesson folder on your USB fl ash drive, then CLOSE the fi le.

CLOSE Word.

Figure 6-19

Convert Table to Text 
dialog box

A nested table, which is a table 
within a table, can be converted.

2.6.2

How do you insert a row?

2.6.3

How do you insert a column?

2.6.4

How do you delete a row?

2.6.5

How do you delete a 
column?
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SKILL SUMMARY

In This Lesson, 
You Learned How To: Exam Objective Objective Number

Create a table Use the Insert Table dialog box. 2.5.1
 Use Draw Table. 2.5.2
 Insert a Quick Table. 2.5.3
 Convert text to a table. 2.5.4

Format a table Use a table to control page layout. 2.5.5

Manage tables Sort content. 2.6.1
 Add a row to a table. 2.6.2
 Add a column to a table. 2.6.3
 Manipulate rows. 2.6.4
 Manipulate columns. 2.6.5
 Defi ne the header row. 2.6.6
 Convert tables to text. 2.6.7
 View gridlines. 2.6.8

Knowledge Assessment

True/False
Circle T if the statement is true or F if the statement is false.

T  F   1.  When you know how many rows and columns you need in a table, the 
quickest way to create the table is by dragging over the grid in the Table 
menu.

T  F   2.  Turning Table Style Options on or off has no effect on the Quick Styles in 
the Table Styles gallery.

T  F   3.  When Word converts text to tables, it uses paragraph marks, tabs, and 
commas to determine how to organize the data within the table.

T  F   4. You can move a column or row using Cut and Paste.

T  F   5. Sorting can only sort one column of data at a time.

T  F   6.  If a hyphen exists within a section of text, and you are converting that text 
to a table, the hyphen will create a new column.

T  F   7. Text can be aligned both horizontally and vertically in a cell.

T  F   8. Word provides four options for changing the direction of text in a cell.

T  F   9. You can sort single-level lists, such as bulleted or numbered lists.

T  F  10.  The Repeat Header Rows button is used for tables that extend to multiple 
pages.

Multiple Choice
Select the best response for the following statements.

 1. Using the Sort feature in a table will sort selected content in what order?

a. Ascending

b. Descending

c. Alphabetically order

d. All of the above
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2. Combining two or more cells into one uses a Word feature called:

a. Split Cells.

b. Merge Cells.

c. Merge All Cells.

d. Merge Selected Cells.

3. An arrangement of data made up of horizontal rows and vertical columns is called a:

a. Menu.

b. Heading.

c. Table.

d. Merge.

4. Built-in preformatted tables that can be inserted and used in your documents are 
called:

a. Table Styles Options.

b. Tables.

c. Quick Tables.

d. Insert Tables.

5. The rectangles that are formed when rows and columns intersect are known as:

a. cells.

b. merged cells.

c. split cells.

d. tables.

6. Which sort order sorts text from the end to the beginning?

a. Descending.

b. Ascending.

c. Plunging.

d. Downward.

7. Sorted data can consist of:

a. text.

b. numbers.

c. dates.

d. All of the above

8. Which option would you choose to arrange data alphabetically, numerically, or 
chronologically?

a. Filter

b. Group

c. Sort

d. Category dialog box

9. When you create a table in Word, two new Ribbon tabs appear. Which of the following 
are in a new Table Tools tab?

a. Page Layout

b. Design

c. Insert

d. Merge Cells

10. The fi rst row of a table that is formatted differently than the rest of the table is called a:

a. total row.

b. banded column.

c. header column.

d. header row.
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Project 6-1:  Placements Table
Ms. Archer, the executive recruiter, asks you to start working on a placements table that will list the 
candidates that have been placed, the companies that hired them, and the date of hire.

Competency Assessment

GET READY. LAUNCH Word if it is not already running.

 1. OPEN placements from the data fi les for this lesson.

 2. Place the insertion point in the last column. Select the last column in the table. In the 
Layout tab, in the Table group, click the Select button and Select Columns.

 3. On the Layout tab, in the Cell Size group, click the down arrow in the Width box until it 
reads .9”.

 4. Place the insertion point in the fi rst column and select the fi rst column in the table. In 
the Table group, click the Select button and Select Columns.

 5. On the Layout tab, in the Cell Size group, click the down arrow in the Width box until it 
reads .9”.

 6. Select the Company column and change the width to 1.5”.

 7. Select the Date of Placement column and change the width to 1.3”. Click in the table to 
deselect.

 8. On the Design tab, in the Table Style Options group, click the Header Row check box 
and Banded Rows check box to turn on. Place your insertion point within the table.

 9. On the Design tab, in the Table Styles group, select the Medium Shading 1 - Accent 1 
style in the ninth column, second row in the Built-In gallery.

 10.  Select the Last column in the table.

 11.  On the Layout tab, in the Data group, click the Sort button. Under the My list has 
section, select Header Row. In the Sort dialog box, click OK. This will sort the column 
by date.

 12.  The table is selected. On the Layout tab, in the Table group, click the Properties button.

 13. In the Table Properties dialog box, click Center alignment in the Table tab and click OK.

 14. Select the header row.

 15. On the Layout tab, in the Alignment group, click Align Center.

 16.  SAVE the document as placements_table in the lesson folder on your USB fl ash drive, 
then CLOSE the fi le.

LEAVE Word open for the next project.

Project 6-2: Quarterly Sales Data
Create a table showing the quarterly sales for Coho Vineyard.

GET READY. LAUNCH Word if it is not already running.

 1. Create a new blank document.

 2. On the Insert tab, in the Tables group, click the Table button. Drag to create a table that 
has 5 columns and 6 rows.

 3. Enter the following data in the table as shown:

          The placements fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.

20XX

 First Quarter Second Quarter Third Quarter Fourth Quarter

Mark Hanson 19,098 25,890 39,088 28,789

Terry Adams 21,890 19,567 32,811 31,562

Max Benson 39,400 35,021 19,789 21,349

Cathan Cook 34,319 27,437 28,936 19,034
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 4. Select the fi rst row. On the Layout tab, in the Merge group, click the Merge Cells 
button.

 5. With the row still selected, center the title by clicking the Align Center button in the 
Alignment group on the Layout tab.

 6. On the Design tab, in the Table Styles Options group, click the Banded Columns check 
box to turn on. The Header Row, First Column, and Banded Rows options should be 
turned on already.

 7. On the Design tab, in the Table Styles gallery, click the More button to display the 
gallery. On the seventh column, choose the orange Dark List - Accent 6.

 8. SAVE the document as quarterly_sales in the lesson folder on your USB fl ash drive.

 9.  On the Layout tab, click the Select button in the Table group, and then choose Select 
Table from the drop-down menu.

 10.  In the Data group, select Convert to Text, then select the Tabs section.

 11.  SAVE the document as quarterly_sales2 in the lesson folder on your USB fl ash drive, 
then CLOSE the fi le.

LEAVE Word open for the next project.

Project 6-3:  Sales Table
Ms. Archer asks you to create a sales table including data from the past two years. She can use this 
table to set goals and project future income.

Profi ciency Assessment

GET READY. LAUNCH Word if it is not already running.

 1. OPEN sales from the data fi les for this lesson.

 2. Select the columns headings containing the months and change the text direction for 
all the months so that they begin at the bottom of the column and extend to the top.

 3. Increase the row height of the row containing the months to 0.9 inches so that the text 
all fi ts on one line.

 4. Use the AutoFit Contents for the selected months.

 5.  Select the last row and Delete.

 6. Make sure the Header Row, Banded Columns, and First Column Table Style Options 
are the only ones turned on.

 7. Merge all the cells in the fi rst row and center the heading.

 8. Merge all the cells in the second row and center the subheading.

 9. Choose the Medium Shading 2 - Accent 2 Table Style format.

 10.  Center the table horizontally in the Tables Properties dialog box.

 11. SAVE the document as sales_table in the lesson folder on your USB fl ash drive, then 
CLOSE the fi le. Leave Word open for the next project.

Project 6-4:  Client Contact Table
Ms. Archer needs you to create a quick contact list.

GET READY. LAUNCH Word if it is not already running.

 1. OPEN client_table_2 from the data fi les for this lesson.

 2. Delete the last four columns: Number of Current Open Positions, Position Title, Date 
Posted, and Notes.

 3. Change the page orientation to Portrait.

 4. Change the width of the Company Name column to 1.9 inches.

 5. Delete the Total row and turn off the Total Row option in Table Styles Options.

          The sales fi le for 
this lesson is available 
on the book companion 
website or in WileyPLUS.

          The client_table_2 
fi le for this lesson is 
available on the book 
companion website or in 
WileyPLUS.
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 6. Change the style to the purple Light List –Accent 4 style.

 7. Center the table horizontally on the page.

 8.  Change the alignment for the fi rst row to Align Center.

 9. Change the header row height to 0.4 inches.

 10. SAVE the document as new_client_table in the lesson folder on your USB fl ash drive, 
then CLOSE the fi le.

LEAVE Word open for the next project.

Project 6-5:  Quarterly Sales Table Update
The Coho Winery’s Quarterly Sales Table includes some formatting mistakes. Find and correct the four 
problems within this document.

GET READY. LAUNCH Word if it is not already running.

 1. OPEN problem from the data fi les for this lesson.

 2. Find and correct four errors in the table.

 3. SAVE the document as fi xed_quarterly_sales in the lesson folder on your USB fl ash 
drive, then CLOSE the fi le.

LEAVE Word open for the next project.

Project 6-6:  Soccer Team Roster
As coach of your child’s soccer team, you need to distribute a roster to all of your players with contact 
information, uniform numbers, and assigned snack responsibilities. You received a rough list from the 
league and you would like to convert it to table form. You haven’t converted text to a table before, but 
you’re confi dent you can do it.

GET READY. LAUNCH Word if it is not already running.

 1. OPEN soccer_team from the data fi les for this lesson.

 2. Select all the text.

 3. On the Insert tab, in the Tables group, click the Table button. Select Convert Text to 
Table from the menu.

 4. In the Convert Text to Table dialog box, key 4 in the Number of columns box. Click the 
Commas button under the Separate Text At section and click OK.

 5. Use what you learned in this lesson to format the table as shown in Figure 6-20. Start 
by removing extra spaces or words, adjusting column widths, and aligning text. Sort 
the table by snack date, insert a header row with the following headings for each 
column (Name, Uniform, Telephone Numbers, Snacks) and choose the Medium 
Grid 3 – Accent 2 Table Style.

Mastery Assessment

          The problem fi le 
for this lesson is available 
on the book companion 
website or in WileyPLUS.

          The soccer_team 
fi le for this lesson is 
available on the book 
companion website or in 
WileyPLUS.

Figure 6-20
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 6. SAVE the document as soccer_roster in the lesson folder on your USB fl ash drive, 
then CLOSE the fi le.

STOP. CLOSE Word.

INTERNET READY

Search the Internet for job openings that interest you. Create 
a table to record data about at least fi ve positions. Include 

columns for the job title, salary, location, contact person, and 
any other information that would help you in a job search. 
Use what you have learned in this chapter to format the table 
in an attractive way that you could easily maintain.

CREATING TABLES
Most people working in business are familiar with the many advantages of using Excel for creat-
ing tables. What some people may not realize is that Word provides many of the same capabili-
ties. By creating a table and performing basic calculations directly within a Word document, you 
can turn an ordinary word processing document into a comprehensive business illustration.

Having just completed your college education, you are excited to begin your new career with 
Woodgrove Bank. As a Banking Associate in the Mortgage Department, one of your main 
responsibilities is to produce a monthly Mortgage Status memo. This memo includes monthly 
information on the number of new mortgage applications, the dollar amount of each, and 
their current status.

Presenting this information in a table format will provide for the most appealing design. However, 
you also need to include a brief introductory paragraph recapping the monthly information, as 
well as calculations for the total dollar amount of new mortgage applications. This report should 
be sent out in a memo format. By using Word, you can easily meet all of your objectives in just 
one program.

A co-worker reminds you that Word provides several memo templates, and you decide to choose 
one when initially creating your document. Memo templates provide replaceable text for To, 
From, Subject, Date, and CC information. Below this, you can enter your monthly recap para-
graph. Finally, you can use Word’s Table options to create and format a table with the desired 
number of columns and rows.

Once the table has been created and the information has been entered into the appropriate cells, 
you can use Word’s Table Layout and Design tools to enhance your table’s appearance. Word 
provides many of the same capabilities you would fi nd in Excel, such as merging cells, splitting 
cells, aligning text, auto-fi tting text, sorting, and much more.

With so many possibilities, Word is a true all-in-one business tool.

WorkplaceReady
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